Baseband: tények és tévhitek

Mivel az egyes firmware-verziók megjelenésekor mindig előkerülnek azok a hozzászólások, hogy “de hát akkor majd ő downgrade-el, és akkor meg van oldva minden, még a függetlenítés is”, így most álljon itt egy cikk a basebandről, és az azzal kapcsolatos tényekről, eloszlatva az esetleges félreértéseket.

A készülék lelke: a baseband

A baseband azon része az iPhone és iPad készülékeknek, ami a készülék mobilhálózattal kapcsolatos kommunikációját biztosítja. Emellett része van a WiFi és a bluetooth funkció működésében is, mert a készülék WiFi és bluetooth eszközeinek MAC címe is a baseband NVRAM-jában található meg; de ezek vezérlését a készülék fő processzora végzi.

A baseband processzor saját RAM-mal rendelkezik, és saját firmware-t tartalmaz a NOR-jában, ami az ARM core-tól és az OS-től is független. A baseband gyakorlatilag egy rendszer-a-rendszerben, és csak egy erőforrás az iOS számára.

Az első generációs iPhone baseband processzora az S-Gold 2-es chip. Az iPhone 3G, az iPhone 3GS és az iPad ugyanerre a célra az X-Gold 608-as chipet használja. Az iPhone 4 basebandje pedig az XMM 6180-as. (A Verizon CDMA-s iPhone 4-ének basebandjéről jelenleg nincs pontos információ, de a hírek szerint a Qualcomm szállítja.)

A baseband egy bizonyos része, egész pontosan a seczone tartalmazza azt, hogy milyen függő az adott iPhone készülék, illetve a baseband firmware-verziójától függ a szoftveres függetleníthetőség.

A baseband alapértelmezetten csak magasabb verzióra frissíthető, mert a chip direkt úgy lett tervezve, hogy ne engedélyezze a downgrade-et.

Ha egy olyan firmware-re próbáljuk meg restore-olni a készüléket, amiben a készüléken lévő baseband verziónál alacsonyabb verziószámú baseband van, akkor a restore folyamat megszakad az iOS fájljainak kiírása után, de még a baseband írása előtt (1015-ös hiba).

Ha a telepítendő baseband verziója egyezik a készüléken aktuálisan lévővel, akkor a restore folyamat vége felé ez ellenőrzésre kerül, a baseband firmware-je nem kerül újraírásra, és a restore folyamat sikeresen véget ér.

Ha pedig magasabb verziójú basebanddel rendelkező firmware-t teszünk fel, úgy az alacsonyabb verziójú baseband frissítésre kerül a magasabb verzióra. (Ha a baseband frissítését sem tudja elkezdeni az iTunes, akkor 1013-as hibát ír – ennek a hosts fájlunk vagy a TinyUmbrella az oka, de ez csak iPhone 4 esetén lehet.)

Az egyes iOS verziók között DFU-ban bármikor mozoghatunk, még jailbreak nélkül is, de a baseband verziója mindig a legfrissebb marad.

Ezen felül az iOS 4.2.1-től kezdve a rendszer betöltés közben ellenőrzi, hogy egyezik-e a baseband verziója a firmwareben található baseband frissítés verziójával, és amennyiben eltérést talál, nem bootol be, hanem recovery módba vált.

A baseband downgrade-je jelenleg kizárólag két esetben lehetséges. Ezek közül az első az 5.8-as bootloaderrel rendelkező iPhone 3G készülékeken működik. A másik esetben az iPad baseband downgrade-elhető speciális módon. A többi készülék és bootloader esetén még nem sikerült olyan hibát találni, ami a downgrade-et lehetővé tenné.

Speciális kivétel viszont a downgrade-et tekintve az iPhone 4 és az újabb készülékek. Ezeknél ugyanis lehetséges a downgrade, de kizárólag csak abban az esetben, ha az Apple még aláírja azt a korábbi firmware-t, amiben a régebbi baseband van. Ez egy-egy új firmware hivatalos megjelenését követően pár óra, de maximum pár nap lehet. Ezután itt sem lehetséges a downgrade.

A baseband verziójához hasonlóan a bootloader verziója sem downgrade-elhető, így ha 5.8-asnál újabb bootloader van a készülékünkön, az sem módosítható. A basebanddel ellentétben viszont a bootloader az iOS frissítéseivel nem frissül, így az 5.8-as bootloaderrel rendelkező készülék bármi szoftverfrissítés után is ugyan úgy 5.8-as bootloaderrel fog rendelkezni.

Kapcsolódó cikkek:

  1. thx a cikket, hasznos volt:)
    olyan kérdésem lenne egyúttal:
    iphone 4 4.1es rendszert 02.10.04-es basebanddel, lehet- e függetleníteni, és ha igen, akkor hogyan?előre is köszi

  2. Én a napokba nagyon megszívtram és az Apple hibájából! Fel updateltem a 4.3 as betat az iphone 4emre… felment simán még aktiválni sem kellett:) De ezzel frissült a baseband is…. utána nem birtam visszarestorolni a 4.2.1 et… mert a 4.3as beta baseband már fent volt… még szerencse hogy van shsh fájlom a 4.1 es rendszerhez amibe még nem volt baseband csekkoló… de most igy jól ki van baszva a fejlesztőkkel mert ha valaki vissza akar térni a 4.2.1 re mert fejlesztő és szar a 4.3 beta… akkor az legálisan NEM TUD! Erre gondolhattak volna

  3. @PetiG87: persze, mert a jailbreakelt iOS esetén ez patchelve van. mondjuk nem tudom, hogyan csináltad, mert iPhone 4-hez jelenleg nincs hivatalos módszer custom 4.2.1 gyártására, csak max valami nemhivatalos bundle, amit lehet, hogy érdemesebb elkerülni.

    @morcego: nem lehet. csak a 01.59.00-t lehet jelenleg. bármi, ami frissebb, azt egyelőre nem.

    @kiru_l: azt lehet, viszont az egyelőre csak tethered módon jailbreakelhető.

    @Wask: gondoltak. a fejlesztőknek szóló kiadási üzenetben mindig ott szerepelt, hogy ne használd a mindennapi készülékeden. a fejlesztők meg általában nem downgrade-elnek, hanem az újabb és újabb beta-kat teszik fel.

  4. @Wask:

    “Apple hibájából” Na ezen ismét jót röhögtem. Csúnya Apple nem engedi, hogy csak úgy ukkmukkfukk dangrédejjjé meg warezojjjá mi? A bitang mindenit nekije.

  5. @dnp: Wask-nak a legutolsó mondatban biztosan igaza van, a többiben is valószínűleg, egyébként a JB főként nem a warez miatt van, hanem a teljesértékű használat végett (de ezt egyébként sokan, sokszor, nálam okosabbak is elmondták…).

  6. @H2CO3: az a baj, hogy az egyszeri júzer szempontjából bizony a jailbreak egyenlő azzal, hogy nem kell megvennie a 200 Ft-os alkalmazásokat… tehát noha neked nem a warez az elsődleges, meg rajtad kívül még sokaknak nem a warez miatt kell a jailbreak, ettől még egyet kell értenem @dnpvel, mert a legtöbben tényleg semmi másért nem jailbreakelnek, hanem csak azért, hogy ne kelljen megvenni semmi alkalmazást.

    ettől még maga a jailbreak nem emiatt született meg, hiszen annak idején még appstore sem volt, meg fizetős alkalmazások sem, mégis volt jailbreak. csak a mai júzereknek már nem szól másról. ez van, itthon sokan még azt a 200 Ft-ot is sajnálják.

  7. Nekem meg ma is egy 2G-m van. Lassan 3 eve megvan, az elsok kozott JB-ztem, de akkor meg nem volt appstore, csak Installerrel lehetett beszerezni mindent. (asszem igy hivtak ami cysia elott futott, mar nem emlekszem ) Most hirtelenjeben csak egy okot tudnek, amiert megerne JB-znem pl az iPademet, hogy a legalban megvett C64 emu ala, be tudjam tolni a mar nagyreszt ingyenesse valt jatek hegyeket.

  8. Ezek szerint a 3G és 3GS-ben ugyanaz a X-Gold 608 processzor van az Infineon-tól.

    Na most az én 2G iPhone-om is így járt két és fél évesen:

    http://index.hu/tech/2010/11/08/tomegesen_mennek_tonkre_a_keteves_iphone-ok/

    A cikk szerint a 3G-k is érintettek, és ebből az következik, hogy a 3GS-ek is azok lesznek, mihely betöltik a két évet (ez nyáron következik be).

    Vajon az I4-eseket továbbfejlesztették, vagy két év múlva azoknak sem lesz WiFi-je?

  9. @gabor94: Erre jo a Gift lehetoseg iTuneson belul 🙂 Kiprobaltam, mukodik a dolog. Bar nem egyszeruen. Az emilben kapott linkkel nem mentunk semmire, nem nyitott meg semmit, de az utolso par karaktert redeemkent felhasznalva siman meglett az ajandek app.

  10. sziasztok. iphone 3gs, T-mobile. 4.1-el. újra szeretném telepíteni a 4.1-et. ennek leírnátok a menetét?-nem szeretném elrontani hogy utána csak az itunes-ról tudjam frissíteni a legfrissebre. köszönöm

  11. @Jadeye: Leírnád nekem hogy hogyan tudom megoldani? Nem gond ha mac kell hozzá. De részletesen, mit töltsek le és honnan. Nagyon megköszönném. Természetesen semmiképp nem akarom az iPad basebandot felrakni.

  12. @Jadeye: igen, ezzel tényleg alapvetően az emberek hozzáállásával van baj, nyilván – sajnos a többség viselkedése miatt – dnp erre gondolt, nade akkor sem az a lényeg benne. 🙂 Anno a Dev-Team (meg előttük pl. Zdidarski) is azért adta ki a jailbreakeket, hogy szabad legyen a telefon, nem véletlenül nyílt forráskódú Saurik egész repója, szintén nem véletlenül írják ki mind a dev-team, mind pl. Geohot (konkrétan a 4.2b3 ipsw-re, valamint a PS3 jailbreakre gondolok), hogy a warezolás ellen vannak.
    @dnp: pl. fájlrendszer elérését -> a készülék jobb testreszabhatóságát, rendszerszintű módosításokat és teljes jogosultságokkal való programfejlesztést, valamint az előbbiekből következően olyan hasznos, ámde alapállapotban letiltott vagy meg sem lévő funkcionalitást, amelyek jól jöhetnek, pl. Bluetooth, SSH-SCP, fájlok letöltése stb…

  13. @gabor94: OTP Junior bankkártya már 16 éves kortól is kérhető, de talán már 14-től is. persze 18 alatt kell szülői hozzájárulás értelemszerűen.

    @chips: a 06.15-ös baseband esetén ugyan úgy működik a GPS – noha csak a gyári Maps app esetén. 3rdparty alkalmazások esetén van elsősorban probléma. a GPS egy külön chip, ami viszont különbözik az iPhone 3G/3GS és az iPad esetén.

    az iPhone 3G/3GS esetén ez egy PMB 2525 Hammerhead II chipset, míg az iPad 3G+WiFi esetén pedig már a Broadcom BCM4750UBG Single-Chip AGPS került alkalmazásra.

    tehát a baseband maga működik a 3G/3GS esetén is, de a problémát az okozza, hogy a GPS chipset más és más.

    remélem, így érthetőbb.

  14. @gabor94: Mert ne lehetne?

    Total Cost: 55,76 Eur
    15446 Ft

    Number of Apps: 71
    Paid: 45
    Free: 26

    Average Cost/Paid Apps: 1,24 Eur

    Ez az iPadem 🙂 Nem JB, Magyar Store. Ennyi. Szep excel tablaban vezetem mit vettem es mennyiert 🙂

  15. én konkrétan azért torom fel a szifonom, hogy hasznalhassak iblacklistet, és eggyetlen programot a Navigont aminek azért busás ára van.(mondjuk meg lehet érteni) ezen kívul minden progi illetve app storos játék amit használok nem haladja meg a 1 €-t, ami azért kifizetheto osszeg… szerintem

  16. Jadeye: OFF kerdezek Toled: Ha megveszek egy appot, azt hany cuccra syncelhetem fel? Mintha valami 5 remlene. Annyi nem lesz itthon ugysem, csak erdeklodom.

  17. Sziasztok, az lenne a kérdésem, hogy ha 4.2.1 béta lett felrakva 3G-re – a baseband verziószám egyezik -, akkor a végleges verzió frissítette a basebandat? Vagy lehet-e ugyan olyan verziójú basbend frissítést csinálni valahogy?

  18. @Jadeye: tudnál vagy bárki aki tud nekem segiteni adott eguy 3GS új boot meg van a 4.2.b3 shsh file jalbreak meg volt 4.2.1. ipsw-vel de nem tudom betallozni a 4.2.b3-at hogy untheter legyen a JB? van valami ötlet
    Mert ipad-en a multkor simán meg tudtam csinálni. köszike

  19. @Jadeye:

    Csak még 1 kérdés.

    A google mapsnál írtad, hogy ott működik a GPS.
    Valóban tökéletes, nem téveszt, és nem az Internetről begyűjtött adatok alapján határozza meg a poziciót a 06.15.00 bb alatt?

    Köszi.

  20. @Jadeye: Fentebb beszéltük hogy 3GS new bootromra lehetséges cudtom 4.2.1et felrakni. Ebben kellene segíteni. A lényeg az hogy ne frissuljon a baseband. A jb nem fontos.

  21. @szorian: nem értem, mi a kérdés. miért nem tudod betallózni?

    @chips: mivel a Maps nem tartalmaz offline térképet, így kell hozzá net.

    @kutitomi: az assisted gps az egy plusz a gps szolgáltatáshoz. ugyanúgy használ gps-t is. http://hu.wikipedia.org/wiki/AGPS

    @kiru_l: gyárts magadnak pwnagetoollal. vagy ha windowsod van, akkor guglizz. beírod, hogy 3gs custom 4.2.1 no baseband update unactivated ipsw download például, és enter.

  22. Hadd ne minosuljon mar downgradenek a legutolso hivatalos ipsw felrakasa!Meg az apple hivatalosan is alairja a restoret! Hagyhatnanak a betaba ilyen rest!

  23. @Jadeye: ha betallozom a 4.2b3 GM verziót miután már a JB meg volt azt irja ki hogy nem unable to recognize specified ipsw pedig anno az ipad-et igy csináltam meg untetherd JB-re

  24. @Jadeye: igen ezt most letöltöm máshonnan hátha rossz az ipsw. ellvileg ha jó akkor utánna jelenik a meg az a lehetőség ahol pipa az untetherd JB-re ugye? redsn0w 0.9.7.b6

  25. @emdanii: jelenleg csak tethered

    @szorian: elvileg igen, betallózod a gyári 4.2.1-et, majd a nextre nyomva lesz egy jailbreak monte opció, azt bepipálod, és ott felugrik egy ablak, amiben be kell tallózni a 4.2.b3-as fw-t.

    @kiru_l: 1. a 47-es hozzászólásban nem szerepel az, hogy hozzám szólnál, nem tudtam, hogy az is nekem szólna
    2. ha nem lehetne feltenni rá a speciális custom-öt, szerinted írtam volna? erre van a pwned dfu mód
    3. ha nem tudna gyártani a pwnagetool, szerinted írtam volna?
    de ha jobban tudod, akkor nem is értem, miért engem nyaggatsz válaszért.

  26. @szorian: nem rossz. inkább az a kérdés, hogy mikor kérdezi a redsn0w, hogy régi vagy új iboot, akkor mindenképp az új iboot-ot kell választanod, másképp nem jelenik meg. de ha iPad fw-t tallózol be, az szerintem nem lesz jó. egy biztos, a cydia ne legyen bepipálva.

  27. @Jadeye: mikor kiválasztom az eredeti ipsw-t akkor feljön egy ablak ahol megkérdezi, hogy ez az ujabb 3gs? majd klikk yes aztán nincs JB mount opcio csak cydia costum bondule, ipad baseband, deactivate, just boot tetherd right now, és just enterd pwned dfu mode right now. erre milyen gombot varjak?

  28. @kiru_l: ha elolvastad a leírást, láthatod benne, hogy kell hozzá a 3.2.2-es iPad firmware, tehát nem, ez nem a netről tölti le a baseband-et. ergo ha nem kapcsolod be, hogy frissítse a baseband-et, akkor nem fogja frissíteni, sem a 4.2.1-esre, sem az iPad-esre.

    de szerintem semmi olyan nincs a 4.2.1-ben, ami miatt azt neked fel kellene tenni, pláne, hogy az jelenleg csak tethered módon jailbreakelhető. én maradnék 4.1-en a helyedben.

  29. iPhone4 4.2.1 – 01.59.00-hoz nem kell se pwnage tool sem custom fw.
    Hosts-ban saurik szerverivel es itunes-ban gyari fw-re update utan tinyumbrella ki tudja szedni recovery-bol es indul a system. A modszerrol van leiras redmondpie-on (csak el van szurva az alt+restore) januar eleje magassagaban asszem es a tinyumbrella krealoja is megerositette twitteren.

  30. @kescar: és ezt te magad is kipróbáltad a saját készülékeden? vagy ha írok egy leírást, hogy hogyan telepíts százforintos kenyérpirítóra androidot, akkor azt is meg lehet csinálni? csak mert amit említesz, nem fog működni, ugyanis:

    “Ezen felül az iOS 4.2.1-től kezdve a rendszer betöltés közben ellenőrzi, hogy egyezik-e a baseband verziója a firmwareben található baseband frissítés verziójával, és amennyiben eltérést talál, nem bootol be, hanem recovery módba vált.”

    @oferi1: ha elolvastad a cikket, olvashattad, hogy nem lehet az alacsonyabb verziószámú basebandet visszatenni, így a 4.2.1-est sem. jelenleg nincs mód rá sehogy.

  31. Sziasztok a 4.3 betahoz kell fejlesztői regisztrácio az aktiváláshoz? Mert irták, hogy álltiolag sikerült aktivállni anélkül is

  32. Üdv! Ha cydia-ban “megjelent” az SHSH: iOS 4.2.1 szöveg, akkor tudok már downgradelni az említett verziószámnál alacsonyabbra (pl. 4.1 vagy 3.2.2)?
    Köszi a választ.

  33. @bazooka: csak akkor, ha van ahhoz is SHSH, tehát írja a cydia a 4.1-et is, de iPad esetén nincs 4.1. iPhone esetén meg nincs 3.2.2. de mivel csak a 4.2.1-et írod, így természetesen nem tudsz.

  34. Jadeye, az en keszulekemen ilyen system fut, tehat igen kiprobaltam es mukodik. Nem keveset hezitaltam elotte, mert a temaval kapcsolatban csupa ilyen bejegyzesekbe futni… hogy valaki leirja hogy muxik es tizen lefikazzak, de mint mondtam notcom is megerositette twitteren a dolog letjogosultsagat, ezert vagtam bele… nomeg, mert csorgott a nyalam az airplay-re es mondom ujra, mukodik. Az teny, hogy visszacsinalni eleg macera, mert restore-al nem megy fel a 4.2.1 (recovery loop) csak 4.1-rol update-el, de ha a cel a 4.2.1… 🙂

  35. @kescar: na igen, ez csak azért működik, mert UPDATE-et nyomtál rá. de RESTORE esetén nem működik. a többség viszont restore-olná, tehát nekik nem jó.

    a redmondpie leírása pedig változatlanul hibás, mert ott a többi hiba mellett egyenesen restore-t írnak (Step 3: … click on “Restore” [Not “Update” or “Check for Update”]), amivel ez nem működik, ahogyan írtam is. kizárólag update esetén megy a dolog.

    ugyanakkor jailbreakelt rendszert változatlanul nem ajánlott update-elni. szerintem nem ér annyit egy tethered 4.2.1, amit nagyon macerás restore-olni, szemben a rendesen birizgálható 4.1-es rendszerrel.

    illetve ami még nagyon fontos, hogy már közben van nemhivatalos bundle a pwnagetoolhoz, tehát azzal már egyszerűbb a dolog.

  36. Tenyleg nem vitatkozni szeretnek, de azert lassuk be, hogy nincs nagy kulombseg egy 4.1 restore (ami tinyumbrellaval egy mezei restore es nem macera es ugye idealis esetben innen indulunk) majd 4.2.1 update es egy elbol 4.2.1 restore kozott, ahhoz kepest, hogy mindenhol halalos foben jaro bunkent van feltuntetve a dolog.

    Ha hozzavesszuk azt, hogy azert hasznalunk mac-et, hogy ne kelljen naponta restartolni, akkor az untethered fel sem tunik. Viszont, ha van akar csak airport express a kozelben, akkor nagyokat lehet flesselni a 4.2.1-re, raadasul gyari fw-vel, kartyafuggetlenul hiszen a baseband a tema.

    Summazva messze nem a kenyerpiritora andoidot temakor szvsz 😉

  37. @kescar: hát pedig elég nagy a különbség egy update és egy restore között, hiszen mint láthatod, az update esetén kiszedhető a recovery loopból, míg restore esetén nem.

    a jelenlegi jailbreak pedig változatlanul tethered, tehát gépre kell dugni. az untethered az, amikor nem kell gépre dugni, hogy betöltsön. igazából semi-tethered a jailbreak, hiszen ha nem telepítesz olyat, ami a springboardba belenyúl (pl mobilesubstrate), akkor be fog tölteni jailbreak nélkül. de a függetlenítés megköveteli a mobilesubstrate-ot, így nem tölt be gép nélkül.

    mivel jailbreakelt a készülék, hiszen másképp nem lehetne függetleníteni, így az meg már eleve nem gyári fw.

    a redmondpie leírása meg hülyeség, mert az úgy nem működik, mert restore-t ír benne. azzal meg nem megy, csak update esetén. leírtam a miértet. értem, hogy neked mi van fent, és értem, hogy megy. de te is érted már, hogy mindez miért van így?

  38. A redmondpie cikk igy ebben a formaban hulyeseg az teny, ezert vagtam be a forumot ami azzal foglalkozik, hogy kell megcsinalni rendesen es irtam is, hogy restore-al nem megy csak update-el.

    Tulkepp csak egy tippet akartam adni, hogy aki akarja az meg tudja csinalni a fuggetlen JB-s iphone4-et 4.2.1 alatt, nem szeretnem emiatt rosszul erezni magam 😀

    Mert, amit mondok az all. Meg lehet csinalni extra hekkeles nelkul.

    Vegulis ez a JB lenyege, nem? Hogy urald a kutyudet… Akit zavar, hogy ez igy tethered lesz, az nyilvan nem vag bele.

  39. Valaki segítsen!
    Van egy iphone 4-esem (4.1, jailbreak) és az asztali gépemmel(win 7 64bit) nem tud szinkronizálni vmi miatt. Egyszerűen rádugom a gépre és ha megnyitom az itunes-t, akkor befagy. Ugyanez laptopon(win 7) hiba nélkül megy. Miért lehet ez? Újra raktam az itunes-t is, de hiába.
    Előre is köszi!

  40. Help!
    Olyan gondom van, hogy a T-s, 4esemen még a gyári 4.1es firmware van, annyit piszkáltam, hogy Limera1n-el JailBreakeltem, illetve persze cydiából pár okosítás… Még az elsők között jutottam hozzá a telóhoz, és mostanrá eléggé be van lassulva a teló. A napokban kezdtem el foglalkozni komolyabban az SHSH-dologgal… Megpróbáltam a cydiás iSHSHit dolgot, de az nem mentette le az SHSH-mat, illetve amennyire utána olvastam, nekem az jött le, hogy már esélyem sincs lementeni, mivel az Apple, mindig csak a legújjabb fw-t írja alá. Remélem ez nincs így, ugyanis szükségem van a JB-re SBSettings és társai miatt is, és a 4.2.1-t ugye csak tehthered módon tudom használni, ami nekem nem játszik…
    Most ezt tényleg megszívtam, és nem tudom újrarakni így? Vagy vki tud egy olyan módszert amivel le tudom még menteni az SHSH-mat?
    Előre is köszönetem a válaszokért…

  41. @Ákos: Engem azért érdekelne a 4.1, mert abban bízok hogy nem fog merülni olyan gyorsan mint 4.1 alatt. Neked hogy bírja az akksi? Nekem jelen állás szerint: 2:56 és 42%.

  42. @kiru_l: Sajnos nincs egyetlen helyes válasz. Nekem elég jól bírja, és úgy látom, leginkább a Pushtól függ, ha azt kiakpcsolom, akkor egész nap alig merül, ha bekapcsolom, akkor estére biztos dughatom a töltőre.
    A WiFit állandóan bekapcsolva tartom, bár napközben a munkahelyemen és este otthon van fix hálózat, nem kell folyton keresnie.
    A 3G-t és a Bluetooth-ot alig használom, így csak a szükséges ideig van bekapcsolva.
    Függhet még az aktiválás módjától, azaz hogy van-e eredeti szolgáltatós SIM kártyád hozzá. Én most a SAM-mal próbálkozom, nem tűnik lényegesen jobbnak, mint a normál aktiválás.

  43. @Ákos: Normál T-mobilos aktiválás. Push csak az msnnek van az is ritkán. Az usage résznél azt írja hogy mennyit nyomkodtad, + a készenléti idők. Tehát nekem kb 24 órát volt készenlétben + 3 órát nyomkodtam, és így került 42% -ra. Tehát ha folyamatosan nyomkodom vegyesen akkor 4 percenként megy le 1%. A játékok viszont 1.5 percenként is lehúznak 1% -ot. Viszont azt vettem észre hogy ha jailbreakelem akkor gyorsabban merül.

  44. Sziasztok!
    Yadeye:
    kérdésem a következő:

    adott egy T-s 3G, 3.1.2-es szoft-al.
    ha ugyanezt akarom visszarakni ,mert már egy éves és kezd megzizzenni, azt hogyan kell??
    gondolom a JB ugyanúgy a végén a blackra1n-al, azt kakukk.
    de eddig hogy jutok el??
    köszi:
    zoo

  45. 6.15-s BB-re csinálhatnának már egy downgrade-t…
    Már jó régóta igérik..
    Egy csomó ember szív a GPS rossz pozicionálása miatt.
    Valaki tud valami örömteli hírrel szolgálni?

  46. @Dr.Zoo: felteheted rá a 3.1.3-mat is gond nélkül, és utána redsn0w 0.9.4, amibe a 3.1.2-es fw-t kell betallózni. inkább ezt ajánlom, mint a blackra1n-t.

    illetve a 3G-t basebandet nem frissítő custom fw-vel frissítheted 4.2.1-re is, már ha a függetleníthetőség is szempont.

    ha nem érdekes a függetleníthetőség, mert gyári független, vagy a hozzá tartozó kártyával használod, akkor meg custom fw sem kell, hanem mehet fel a gyári fw, és frissülhet a baseband, és jailbreakelheted a redsn0w 0.9.6rc8 segítségével.

  47. Szia!
    köszi, a függőség sajnos szempont, eredetileg trémobilos a teló, váltok 4G-re, és akinek ajándékba adom megigértem hogy újrahúzom a szoftot, mert már eléggé tré.. akkor letöltöm (valahonnan a 3.1.3 -as szoft-ot, és utánna hogy tallózom be a 3.1.2-es fw-jét?) bocsi, kicsit láma vagyok hozzá 🙂
    esetleg ha tudsz egy mélt dobni hálás lennék: zoltan pont varaljai kukac elmu pont hu köszi!!

  48. @Jadeye: Valahogy megoldható a jelenlegi baseband frissítése? Csak mert van egy 3GS-em (4.2.1 BB: 05.13.04) régi iBootal gyári kártyával aktiválva, de nem működik a push és, ha be van kapcsolva baromira zabálja a mobilnetet még akkor is, ha Wifi hálózaton vagyok.Valakinek ötlet?

  49. @Jadeye: Nem akarok az idegeitekre menni, de már vagy 2-3 alkalommal kommentben is megírtam, de valamiért senki nem reagál… Szóval, 20-án küldtem egy mail-t (1phonehublogkukac…), de azóta nem jött válasz. (2G kijelzőcsere). Előre is köszi!

  50. @pAnk: megnéztük, de nem találtunk ezzel kapcsolatban semmit. el tudnád küldeni megint? egyébként hardveres ügyekben lehet egyszerűbb lenne az iSzervizPontnak írni, hogy mi irányítottunk hozzájuk, mert mi is nekik adjuk át a hardveres dolgokat, mert ők a hardveres szervizünk.

  51. @Jadeye: Köszönöm a választ! Régen volt kint az oldalon pár iPhone-nal foglalkozó kolléga elérhetősége és volt egy fejér megyei cím is. Igazából nekem az lenne a jó, ha lenne valaki aki itt (FM) tudna nekem hardware ügyben segíteni, mert sajnos ritkán járok Pestre.

  52. @Ceko: ha függetleníteni is akarod, akkor nem lehet megoldani, mert az aktuális baseband nem írható újra. állítottál vissza bármit korábbi backupból? ha NEM érdekes a függetlenítés (bár az iOS + baseband verzió kombóból úgy értelmezem, hogy bizony függetleníteni kell), akkor egy szimpla gyári restore frissíti a basebandet 05.15-re, de az ugye alapból nem függetleníthető, tehát ezt csak akkor csináld, ha gyári független, vagy eredeti kártyával használod. más opció nincs, mert ahogy a cikkben írtam, az aktuális baseband nem írható újra ugyan arra a verzióra, csak frissíteni lehet.

  53. Ettől a választól tartottam. 🙁 Soha semmit nem rakok vissza backup-ból. Akkor ezek szerint várnom kell valami újabb BB függetlenítésre.Jahh, és az a durva , hogy visszaraktam a 4.0-t ami ugye ehhez a Baseband-hez (05.13.04) tartozik és úgyis meghülyült a push és zabálja a mobilnetet.Ezért gondoltam, hogy BB zavarodott meg és ráférne egy frissítés, de ezek szerint nem lehet 🙁 🙁 Azért köszi.

  54. @Ceko: Van hogy a push meghülyül, én azt tenném a helyedben, hogy csinálsz egy custom restore-t az aktuális BB verzióhoz megfelelő szoftverről. Tudom hogy jayede nem ajánlja de én a sn0wbreeze -el csináltam, és utána megjavult a push. Feltolod ezt a custom fw-t és reménykedsz 🙂

  55. Sziasztok

    Érdeklődnék, hogy tudnátok e segíteni egy iphone 3g 16 gb-vel kapcsolatban.
    Pénteken vásároltam használtan,semmi hiba nem volt vele, majd este itunes-on ki szerettem voltam restoros-olni, mivel tele volt minden féle adattal meg miegymásokkal (A telefon magyar t-mobilos) .Már majdnem befejeződött az egész amikor a 1015 hibaüzenet megjelent,és azóta recovery módból nem jön ki. Ha jól tudom 4,2,1 volt rajta és jailbreakelt is volt.
    Már szinte mindent kipróbáltam de az eredmény negatív.
    Amiket próbáltam : Ireb,tinyumbrella,recboot.
    Üdv Zsolesz

  56. @zsolesz79: talán olvasd el a cikket, hiszen le van írva benne… valószínűleg 06.15-ös baseband van rajta, ez okozza a problémát:
    “Ha egy olyan firmware-re próbáljuk meg restore-olni a készüléket, amiben a készüléken lévő baseband verziónál alacsonyabb verziószámú baseband van, akkor a restore folyamat megszakad az iOS fájljainak kiírása után, de még a baseband írása előtt (1015-ös hiba).

    […]

    Ezen felül az iOS 4.2.1-től kezdve a rendszer betöltés közben ellenőrzi, hogy egyezik-e a baseband verziója a firmwareben található baseband frissítés verziójával, és amennyiben eltérést talál, nem bootol be, hanem recovery módba vált.”

    futtass le rajta egy greenpois0n-t, akkor be fog bootolni, de még aktiválnod kell majd a T-mobile-os kártyával.

  57. Sziasztok

    Bocs a láma kérdésért, teljesen új vagyok!
    05.15.04-es baseband-el lehet már, vagy készül a megoldás függetlenítésre?
    Illetve ha igen GPS megy rendesen? Köszönöm!

  58. Sziasztok!
    Barátom kapott 1db 3g-t 2.2.1sw és 02.30.03 a baseband verzioja. Hogyan tudnám ezt az ókori basebandet frissíteni az 05.13.04-re. T- Austria függö és szeretném, ha nem lenne az. Szeretném a GPS-ét használni. Elöre is köszönöm a segítséget.

  59. @Kisember: két lehetőséged van:

    1. ha van SHSH a 4.0 vagy 4.0.1 vagy 4.0.2-höz, akkor ezek gyári verziójával restore, az frissíti a basebandet a 05.13-masra. majd onnan custom 4.2.1 segítségével felmegy rá a legfrissebb elérhető fw.

    2. ha nincs SHSH-d a fentiekhez, akkor fuzzyband a cydiából, az bármi esetben tud 05.13-ra frissíteni (downgrade viszont csak 5.8-as bootloader esetén megy).

    ha nem boldogulnál vele, vagy inkább bele sem kezdenél, és ránkbíznád, írj a mailcímünkre.

  60. Sziasztok.

    Óriási hibát követtem el, mikor barátom iPhone 3GS-ének iTunes-án nyomtam egy frissítést, gondoltam miért ne… Előre leszögezem, hogy egyikünk sem értett iPhone-hoz… Én speciel Android-ot és Windows Mobile-t buheráltam, és ezekre alapozva nem is feltételeztem, hogy visszavonhatatlan hibát vétek.

    Ugyanis mint kiderült, egy Jailbrake-elt custom rom VOLT rajta, és szoftveresen volt függetlenítve.

    Ezután az aktiválásnál elakadtam, mert nem történt semmi… Próbáltam iTunes-os, és WIFIst.

    Na jó, akkor valahogy eljutottam oda, hogy Jailbreak. Redsn0w szépen meg is csinálta, elindult a teló, aztán Cydia: CORONA 5.0.1 untethered is meg lett.

    Jelenlegi problémám, hogy NINCS SIM vagy KERESÉS a státuszbáron, így használhatatlan…

    Próbáltam az ultrasn0w-t a cydia-ról, de semmi… próbáltam a “mobile…” package-et frissíteni, de szintén semmi…

    Aktuális adatok:

    iPhone 3GS 8GB
    iOS 5.0.1
    Baseband 6.15.00
    New Boot
    2010-es gyártású

    Előre is köszönöm

  61. Sziasztok,
    a múlthéten vettem egy iPhone 4-et (16Gb), állítólag valamilyen angol szolgáltató függő, 6.1.3-as firmware van rajta, 04.12.09-es baseband-el, valahogy lehetne ezt függetleníteni? Már rengeteg kerestem, de nem találtam semmi használhatót.
    Köszi előre is a segítséget! 🙂

  62. Miután írtam kipróbáltam azt (próba szerencse alapon),hogy rádugom itunes-ra a telót amikor benne van a simkártya,ugyanis eddig csak piszkáltam a cydiát(ultrasn0w-tól kezdve minden fenét piszkáltam,eredmény nélkül), végül felvillant a telefon és kiírta hogy telekom hu….:) Tehát most nem értem,hogy gyárilag független a telefon vagy valamit sikerült elérnem ezekkel a birizgálásokkal…:D De kétlem,hogy az utóbbi lenne.:) Azóta nem máködik a cydia,a mail, és a safari, de legalább vannak ezekre az appokra más alternatívák. 🙂 Ha elég bátor leszek updatelek 7.0-ra, csak tartok tőle ha updatelek megint nem talál majd szolgáltatót.:S
    Minden esetre köszönöm szépen a gyors választ! 🙂

  63. Kihagytam, hogy próbáltam még gyári visszaállítást is, a beállításokban, aztán 10percig csak pörgött, végül meguntam és kikapcsoltam a telefont, azóta áll ez fenn,megoldaná a problémát ,ha megint megpróbálnám factory resetet?:S

  64. @schwarcz: mint írtam, az említett baseband nem függetleníthető szoftveresen, hiába próbálkozol, nem kompatibilis vele az ultrasn0w. sehogy. fentebb linkeltem a cikket, amiben az összes függetlenítési lehetőség le van írva, azok közül az említett basebanddel kizárólag a gyári típusú megoldás működik.

    jailbreakelt készüléken tilos használni az “összes adat és beállítás törlése” opciót: http://szifon.com/2013/03/04/szifon-source-visszaallitasi-opciok-fix/

    amikor újraindítás után ez vagy az nem működik, az meg még mindig azért van, mert tethered jailbreak: http://szifon.com/2011/09/23/gyakori-kerdesek-mi-a-tethered-es-untethered-jailbreak-kozt-a-kulonbseg/

  65. Segítsetek légyszíves, ki lett függetlenítve a 3GS telefonom, 4.1-es ios és 06.15-ös BB lett rátelepítve. Ahogy olvasom ez a BB nem engedi működni a GPS-t, hát nekem sem működik. Én most rátettem egy 05.13.04-es Baseband-et, de továbbra sincs GPS. Mit tehetnék?
    Köszönöm

  66. [link törölve.]
    A fenti leírás szerint csináltam, de mivel a telefonom a 6.0 ios-t nem telepítette fel, mert 2011. nem emlékszem már milyen hó előtti, ezért a 4.1-el telepítettem a redsn0w win 0915b3-at. Ráment a 06.15.00 baseband, rajta van a cydia is. Így nem működött a GPS. Mivel olvastam, hogy ezzel a BB-el nem működik, ezért újra indítottam a redsn0w-t és ekkor már kipipáltam , hogy ne legyen rajta az iPad baseband. Így sem megy..

  67. @mkjudit: a készülék sorozatszámát mindenképp tudni kellene. másrészt most akkor 4.1 van rajta?

    a telefonodra a 6.0 nem azért nem ment fel, mert 2011 akármikori, a megjelenési ideje kizárólag az iPad baseband miatt fontos. ehhez kell a sorozatszám. a 6.0 azért nem ment fel, mert az Apple már csak a 6.1.6-ot írja alá a 3GS számára, és mentett SHSH nélkül így nem tehető fel más: http://szifon.com/2013/04/01/gyakori-kerdesek-az-aktualis-ios-verzional-regebbi-firmware-visszaallitasa/

    amit én tennék: frissítés gyári 6.1.6-ra (jelenleg nem lehet custom-öt készíteni), tethered jailbreak 6.0-val, iPad baseband felrakása, majd downgrade, ezután just boot, cydiából p0sixpwn csomag telepítése (ezzel untethered lesz a jailbreak), majd ultrasn0w telepítése. ha mindent jól csináltál, a készülékeden a baseband 05.13.04 lesz, iOS 6.1.6, untethered jailbreak.
    http://szifon.com/2012/06/18/ipad-baseband-downgrade-iphone-3g3gs-fuggetlenites/
    http://szifon.com/2012/10/14/gyakori-kerdesek-az-iphone-fuggetlenitese/

    ha ezek túl kínaiul hangzanak, akkor hozd be a szervizbe, és megcsinálják a kollégák: http://iszervizpont.hu/kapcsolat

  68. @mkjudit: ez akkor megfelelő, hiszen a sorozatszám lényeges karakterei 88039, ami a kérdéses xx135-nél alacsonyabb, így az iPad baseband nem okozhat gondot. akkor én azt tenném vele, ami fentebb írtam, és úgy szerintem jó lesz. ha nem sikerül, akkor be kéne hozni a szervizbe.

  69. T -mobil függő, ilyen kártyám nincs csak telenoros, tehát nem tudtam aktiválni, csak jailbreak után magától elindult. Szeretném használni a navigációt de mindig azt írja, hogy nincs GPS. Köszi, hogy foglalkozol velem!

  70. @mkjudit: ha nem eredeti kártyával aktiváltad, akkor nem megy a push, így az attól függő szolgáltatások, tehát a find my iPhone sem. kérj valakitől egy T-s kártyát, a készüléken válaszd ki az összes beállítás törlése opciót (figyelem: NE az összes tartalom ÉS beállítást!), és aktiváld a T-s kártyával. lejárt kártya is jó.

Írd le a véleményedet! Moderációs elveinket ide kattintva olvashatod.

Hozzászólás írásához be kell jelentkezned!