Történelmi hír: az Apple lehetővé teszi az appok korábbi verzióinak letöltését az App Store-ból!

Ez a cikk legalább 1 éve frissült utoljára. A benne szereplő információk a megjelenés idején pontosak voltak, de mára elavultak lehetnek.

Az App Store egyik nagy hátránya volt, hogy az appok frissítéseivel azok alapkövetelménye az iOS egyre magasabb verziói lettek, így a régebbi készülékek tulajdonosai csak az adott app IPA fájljának lementésével tehették azt fel, ha az app frissült, és az App Store-ból nem. Ez most megváltozott: az Apple mostantól lehetővé teszi, hogy letöltsük az adott app azon verzióját, ami a készülékünkön futó iOS-t még támogatja!

Az alábbi képen egy iPhone 3G és iOS 4.2.1 esetén teszteltem a nemrég frissített Szifon.com appunk letöltését. Az appunk 2.0-s változatához már mininum iOS 5.0 kell, de a szokásos inkompatibilitási figyelmeztetés helyett most teljesen mást dobott fel a rendszer:

regi_verzio_letolese_01

Az Apple üzleti modellje eddig nem tette lehetővé, hogy egy adott app korábbi verzióját letölthessük az App Store-ból, így mindig csak az aktuálisan legfrissebb verziós app az, ami elérhető. A Szifon.com alkalmazás 1.2.1-es verziójának még iOS 4.0 volt az alapkövetelménye, majd a most elérhető legfrissebb, 2.0 már iOS 5.0-t igényel, ezért nem telepíthető iPhone 3GS előtti eszközökre, hiszen azokra sosem jelent meg már a 4.3 sem. Így az ilyen készülékeket használóknak résen kellett lenniük, és ha el is veszett az iTunes könyvtárából az adott app, de a készüléken még telepítve volt, akkor a vásárlások átvitele menüpont visszamásolta azt a készülékről a számítógépre, és így lehetett készíteni róla egy biztonsági másolatot is.

Ha valaki viszont bármilyen módon elvesztette egy adott app megfelelő verziójú app IPA fájlját, és a készülékéről is sikerült azt bárhogy törölni, azok számára nem igazán volt megoldás, hogy feltelepíthessék. Mostanáig.

A Download gombra nyomva el is indult a letöltés, ami közben egyébként az új verziós app ikonját mutatta a rendszer:

regi_verzio_letolese_02

A letöltés és telepítés végén pedig az app korábbi verziójának ikonja virított a képernyőn, és elindítva már ki is derült, hogy valóban a korábbi verziót töltötte le az App Store-ból a készülék. (Ha korábban még nem töltöttük le az adott appot egyszer sem, akkor a számítógépen, iTunes-ban a legfrissebb verziót leszedve már a készülékünkön letölthetővé válik a régebbi verzió a régi készüléken.)

regi_verzio_letolese_03 regi_verzio_letolese_04

Szifon.com
  • Szifon.com
  • Méret: 19.3 MB | Verzió: 3.2.5
  • Ár: Ingyenes | Értékelés:

Úgy tűnik, hogy ugyanezt sajnos az első generációs iPhone és iOS 3.1.3 esetén viszont nem lehet megcsinálni. Ott például a Bpmenetrenddel próbáltam meg ezt, mert a Szifon.com appunk korábbi változatához is minimum iOS 4.0 kellett. Itt csak a korábban megszokott hibaüzenetet kapjuk, noha a Bpmenetrend 1.1.8-as verziója még gond nélkül futott 3.1.3 esetén is:

BpMenetrend_3.x_4.x

Ebből arra lehet következtetni, hogy minimum iOS 4.0 szükséges az appok korábbi verzióinak letölthetőségéhez. Ezért aki első generációs iPhone-ra szeretne Bpmenetrendet, annak marad a jailbreakkel elérhető csomagunk, iPhone 3G-re pedig így már jailbreak nélkül is letölthető az 1.1.8-as változat.

BpMenetrend
  • BpMenetrend
  • Méret: 15.25 MB | Verzió: 2.1.0
  • Ár: Ingyenes | Értékelés:

Ez mindenképpen egy történelmi lépés az Apple részéről. Eddig azt lehetett mondani, hogy egyszerűen üzletpolitika volt, hogy nem volt erre lehetőség, mert így egy idő után az alkalmazások elérhetősége miatt is rákényszerül az ember a frissítésre, vagy az új készülék megvásárlására. De most, hogy az App Store lehetővé teszi, hogy akár iPhone 3G esetén is letöltsük még a régebbi, iOS 4.3 előtti verzióit, sok régi készülék új életre kelhet.

Neked van még régi készüléked, amin ez a lehetőség jól jön majd?

Eredmények megtekintése

Betöltés ... Betöltés ...

Ezek még érdekelhetnek:


  1. @pityu: alapból törlünk minden offot, de erre most válaszolnék: az appban mi döntjük el, miről megy push, és miről nem. nem akartunk minden cikkről pusht küldeni, az sokszor zavaró lehet, így csak az általunk fontosabbnak tartott hírekről küldünk, mint amilyen ez is. 😉

  2. Nem hiszem, hogy az iOS 7-hez van köze, hanem a 64-bit-es programokhoz. Ha a fejlesztő frissíti a programját 64-bit-re, akkor a régi készülékekre nem lenne többé letölthető. Ennyi.

  3. @Csapszi: passz, egyelőre nincs róla részletesebb információ, de mivel épp az iOS 7 megjelenése előtti napon bukkan ez fel, így szerintem (és az azóta már külföldi oldalakon is megjelent cikkek szerint) ehhez lehet kötni. de ha lesz róla részletesebb információ, azt is megosztjuk majd.

    @Tenax: ha a 32/64 bit váltás miatt lenne, akkor nem kellene, hogy olyan régi verziót is odaadjon a Store, ami 4.2.1-en fut, hiszen ott ez a probléma még fel sem merült.

  4. Ez egy jo hír, van ket rossz 3g-n otthon amiből egy jót össze dobhatnék, de eddig nem volt értelme nekiállni hiszen szinte már semmi sem ment rajta. Valamint a regi 3gs em is a csaladban maradt, itt sem lez gond igy az ios 7 el erkező frissitesek. Jó hír…

  5. @AppleFan: 3GS-től kezdődően ez megoldható SHSH + DFU kombóval, kivétel iPhone 4S-től felfelé. szerintem nem fogják engedélyezni, maximum az iOS 7 nem lesz kötelező, bár az is túlzottan meglepő lenne.

  6. @AppleFan: tényleg ez lenne a szép és a korrekt.. csak akkor nem tudnák majd azt kihozni milyen sikeres ios 7 mert így hiába nem fog tetszeni sok embernek vissza lépni nem fog tudni, csak a hókusz-pókuszok. sé nem azért vesz az ember egy ilyen megbízható telefont, hogy hókusz-pókuszolni keljen.

  7. Felesègembak iphone 5 ost vettem kb 3 hete, ugye holnap jon ki az ios 7. Szeretnè kiprobàlni de attòl fèl hogy nem tetszene neki akkor azon “ragad”. Ezert irtam hogy az mèg jó lenne ha legalább erre gondolnának… remelem fognak…

  8. Ha jol ertem ez csak a kompatibilatasi gondok elkerulesere jo. Pl a c64 emulatorbol nem tudom letolteni a 2-3 verzioval korabbit, amiben megveheto volt a last ninja sorozat, mig az ujbol kiszedtek a gyokerek…. Kenytelen vagyok hackelni a cuccot, es az ujba visszatolni a jatekaimat.

  9. Valaki tudna segíteni, és elküldené a “Vodafone Navigation Hungary” alkalmazást? Nem engedi letölteni, túl nagy, kellene hozzá Wifi, de a régi megboldogult 3G-men már nem működik, pedig de jó lenne autóba navigációnak…
    Please, valaki feltölti wetransfer.com -ra , vagy valahova, ink pediglen ide?
    Köszi! : )

  10. Affene, nekem iPhone-om van, tehát nálam nem fog működni. Kár, mert a Whited00rral és az Apptimemachine-nal csúnyán befürödtem, és vissza kellett raknom a 3.1.3-at, amit azóta töretlenül használok, mert már JB-zni se volt kedvem. És iszonyúan vigyázok a régi programokra, nehogy véletlenül frissítsem őket, úgyhogy két iTunes libraryt kell tartanom az iPad2 miatt.
    Tanulság: SOHA ne vegyél meg egy első generációs Apple terméket!

  11. @norbesz74: mármint mi nem fog működni?

    @dnp: nem a kompatibilitási gondokra jó. hanem arra, hogy például ott volt a Bpmenetrend 1.1.8-as verziója, de az App Store-ból az már nem tölthető le alapból, hanem csak a legfrissebb. most viszont egy iPhone 3G-re, amin 4.2.1 van, és amit így a Bpmenetrend legújabb verziója már nem támogatna, arra az Apple odaadja az app régi, 4.2.1-en még futó verzióját.

    @Parittya1: hiába tölti le más a saját ID-jával, a jelszava ismerete nélkül az iTunes-od nem fogja feltenni azt a készülékedre, mert nem lesz authorizálva hozzá.

    @rgbx: nekem is van első generációs iPhone-om, de ebben az esetben úgy tűnik, hogy a 3.1.3 nem támogatott, de ez még akár változhat is a későbbiekben, bár kicsi a valószínűsége. ez a gond persze nem érint, mert archiválva megvan az összes olyan app, ami az iPhone 2G-re kell. neked is ezt tanácsolnám, írd ki ezeket egy DVD-re, vagy külső winyó, pendrive, és akkor tuti meglesznek.

  12. Én még annak örülnék, ha nem csak a rendszer kompatibilitás miatt, hanem akár szabad akaratból is lehetne régebbi verziót letölteni. Van jópár olyan alkalmazásom, aminél ha tehetném, akkor régebbi verziót használnék, mert a frissítéssel olyasmit nyírtak ki, vagy csesztek el a fejlesztők, ami nekem fontos volt.
    Régebben volt JB ájfónomon is, meg ájpedemen is, de mindig okozott valami nem várt kellemetlenséget. Most csak ájpedet használok iOS vonalon, így mivel nem elsődleges, mindennapi eszköz, amin kommunikálok, ezért a stabilitás nem elsődleges, és elgondolkodtam újra a JB-n, mivel az almának még mindig nem sikerült lenyomnia a torkomon, hogy ők jobban tudják, hogy mi a jó nekem, mint én.

  13. @skandigraun: a korábbi verziókat letölteni jelenleg csak a készüléken lehet, az iTunes-ban nem, de a készülékén valami nem jó a wifivel, 3G-n meg nem fog tudni letölteni több száz MB-ot, mert az iOS maga nem engedi.

    @KrE82: készíts rendszeresen mentést az appok IPA fájljairól, más egyelőre nincs.

  14. @Jadeye: Köszi, le vannak mentve. Sajnos nem bízom benne, hogy támogatni fogják, mert a sima AppStore se működik már rendesen ezen az iOS-en. Eltűnnek a Back gombok, újratölti az oldalt x másodpercenként, miközben görgeted a leírást, visszahoz régebben megnézett appokat. Pedig szűz restore, nem állítottam vissza semmit, csak az appokat telepítettem újra. Egyébként is ha jól tudom az AppStore web alapú, hogy távolról tudják frissíteni a működést, és mivel módosítgatják a szkripteket is, egy-két éve már nem jól működik ezen a régi rendszeren, és emiatt egy újabb restore sem segítene rajta. Még egy érv arra, hogy nem lesz változás: nagyon kevés fut ezekből a veteránokból, az Apple-nek nem éri meg foglalkozni velük.

  15. @KrE82: Ellentétben a Windows Phone-nal az iPhone-on régóta elérhető az iTunes-ban a “Transfer Purchases” opció (bár az újabb verziókban igyekeznek nagyon jól elrejteni), ezzel lementi a készüléken található aktuális verziót és egy IPA fájlban tárolja abban a könyvtárban, amit iTunes Librarynak választottál. Pl. Users/loginnév/Music/iTunes/iTunes Media/Mobile Applications

    Mindig az iPaden frissítsd az appokat, próbáld ki, aztán ha nem jön be valamiért, az iTunesszal bármikor visszateheted a régit úgy, hogy törlöd az iPadről az appot, és PC-ről telepíted újra az iTunes Libraryból. Ez viszont sajnos az app minden helyben tárolt dokumentumát (pl. játékállás) törli.

    Ha ezt el akarod kerülni, akkor az új alkalmazás felrakása előtt kell csinálnod egy backupot is, és a régi verzió visszarakása után pedig vissza kell állítanod a backupot. Sajnos ez viszont minden mást is felülír, ami a backup óta változott a készüléken, mivel hivatalosan (még) nem lehet alkalmazásonként backupot visszatölteni, de pl. jailbreak után vannak erre nagyon jó appok (AppBackup), amikhez még PC sem kell.

    Áthidaló megoldásként iTunesos backup helyett egy PC-n futó okos külsős alkalmazással (pl. iFunBox) lementheted az adott app Documents és Libraries könyvtárának tartalmát (aka sandbox), majd ha esetleg vissza kell állítani a régi verziót, akkor visszamásolni. Csak ez meg kissé kényelmetlen.

  16. 5.1.1 es JB-s iphone 4 em van eddig volt egy pár app amit nem tudod apstore updeteleni mert ugye tört appok voltak és folyamatosan mutatta, de most az írja hogy all apps are up to date? Most akkor mi van !!!!!! nem is lehet up to date, mert tudom hogy azokból van ujabb verzio is!

  17. Most tettem egy próbát az instagram nem jelent meg az app storeon belül az updates menünél.
    Viszont ha a searchnél rákerestem az instagramra és ott rányomtam máris írta hogy update és frissitette. Tehát valami nagyon nem stimmel itt!
    Gyakorlatilag eltűnt az updates lista appstoreban

  18. Aha, nagyon jó, hogy engedi, mivel az Infinity Blade III megkérdezte, hogy akarok e régebbi verziót és rányomtam reflexből, hogy igen de azután jöttem rá, hogy ha iOS 7 vagy későbbi a követelmény, akkor nincs régebbi verzió. IB IIl-mal együtt elkezdte tölteni az iOS 7-et amit eszem ágában sem volt letölteni, megállítottam még időben. Miután letölti azután rákérdez arra, hogy telepítse? vagy rögtön teszi is föl? Nem akarom feltenni, használtam GM-et, nem kell. Pls segítsetek.
    Remélem nem vagyok off-os

  19. Ez jó hír, mert végre eltűnik a badge az Appstore-omról, amit azoka az appok okoznak, amiket 5.0.1-re nem lehet feltenni, viszont az igazi problémámat nem oldja meg, miszerint ráerőltetni a nagyobb iOS verziószám igényű appokat az enyémre 🙂
    De úgy látom, valami hiba van időnként, mert most visszajött, hogy 15 app vár frissítésre. Updateltem hármat gyalog (mármint egyesével) és ettől az összes App up to date lett 🙂

    És ha már így előkerült: nem tudtok egy módszert, hogy legalább 5.1-et igénylő appokat valahogy feltegyek 5.0.1-re? Frissíteni sajnos nem tudok (7-re soha, 6-ra is csak a frissítési lehetőségek miatt mennék, de ugye elbuknám a JB-t, ami rosszabb lenne, mint újabb appokat futtatni).

  20. Sziasztok!

    iPad2-ről sikeresen törölve lett egy program. ( v6.0 ) Már nem találom meg az Appstore-ban. Van valami megoldás arra, hogy visszategyem? IPA file valahol megtalálható az iPad-en?

    köszi

  21. Sziasztok!
    Most valamivel nem vagyok tisztába… Ez most azt jelenti hogy régebbi facebook verziot telepithetek az iphoneomra? Mert pl én régebbi facebook verziot szeretnék telepiteni ahol még felül találhato az értesités menü, az üzenet, stb… segitségeteket elöre köszönöm 🙂

  22. Elméletileg igen, gyakorlatilag nem tudom hogy működik a dolog.
    Régebbi fb-t szerettem volna telepíteni, de a store-ban csak a legújabbat látom, ami jelenleg nem is telepíthető.
    Kénytelen voltam alternatív megoldást keresni, végül sikerült egy régebbi fb-t telepítenem.

  23. Sziasztok!

    Előre bocsánat, de én most ismerkedem az iOS világával. Android fronton képben vagyok. És keresem az analógiákat.

    Tehát: az egyik külhoni rokon nekünk adta az iPadját. Első generációs, 64GB-os, 3G-s ketyere. Tetszetős darab. Nem kérdés. De miután csinálnom kellett Apple ID-t, még mindig nem engedett egyetlen játékot sem frissíteni, mert nem én voltam az, aki először/utoljára feltette. És miután vagy 5 ID került elő a végére, gondoltam, hogy ok. Mehet az androidos terminológiában factory reset. De ez hibára futott. Tekert a kor ikon, míg ki nem merült. Lehet, hogy azért, mert nem az enyém volt az elsődleges fiók. Ok, mondom, akkor a PC-s iTunes, restore iPad hátha segít. Ez már végig is ment, de boot után az addig tökéletesen működő villanykönyvolvasó alkalmazás már nem települt fel, mert iOS 7-re vágyik. Ez meg ugye csak 5.1.1 (ha jól emlékszem).

    Lelkesen olvastam a cikkben itrakat, de nekem bizony nem jön olyan ablak, hogy régebbi verziót tenné fel.

    Van esetleg ötlete valakinek?

    Alapvetően hiányzik a Google ökoszisztéma. Gmail, Chrome. De ezek is iOS 7-hez kötöttek.

    Valahol hihetetlen, hogy egy egykoron negyedmilliós zászlós hajót így leírtak.

    Kérdésem: hogy lehetne ebből egy jó villanykönyvolvasóm? (epud, prc, mobi, pdf, esetleg képregény, olykor rengeteg képpel)

    Segítségeteket előre is köszönöm!

  24. Sziasztok! Segitsegre lenne szuksegem. Ujraraktam a regi 3gs-em, uj apple ID-t hoztam letre. Probalom letolteni facebook appot, elvileg felkene dobnia a regebbi verzio letoltese lehetoseget de csak annyit ir hogy nem kompatibilis iOS 7 alatt. Hogyan tudnam orvosolni a problemat? Valaszokat elore is koszonom!

  25. @István Nagy: látatlanban ezt valószínűleg senki nem fogja tudni megmondani. korábban letöltötted már ezzel az Apple ID-val az adott appot? ha nem, akkor ezt próbáld meg >> (lentebb)

    @Rotary: próbáld meg először egy olyan készüléken letölteni ezzel az új ID-val az adott appot, amit az támogat, majd ezután próbáld meg a 3GS-en ugyanezzel az ID-val.

  26. @Jadeye: Koszi, igy mar sikerult letoltenem azt az eggyet. De a tobbi a appnal ezt mindig meg kell csinalnom. Pedig ha jol emlekszem ez regebben mukodott rendesen mindennel.

Írd le a véleményedet! (Moderációs elveinket ide kattintva olvashatod.)

Hozzászólás írásához be kell jelentkezned!