Engedélyezd a Continuity-t az azt hivatalosan nem támogató Mac-eden!

Ez a cikk legalább 1 éve frissült utoljára. A benne szereplő információk a megjelenés idején pontosak voltak, de mára elavultak lehetnek.

Az OS X 10.10 Yosemite és az iOS 8 talán egyik leghasznosabb kényelmi funkciója a Continuity, amely lehetővé teszi, hogy Mac gépeink és iOS-készülékeink között minden eddiginél szorosabb kooperáció jöjjön létre. Így például egy, az iPhone-unkra érkező hívást fel tudunk venni a Mac-ről, vagy az iWork irodai programcsomag használata során ott folytathatjuk az egyik készüléken a munkát, ahol a másikon abbahagytuk, illetve az AirDrop már iOS és OS X között is működik közvetlenül.

continuity

Ezeknek a lehetőségeknek egy részéhez viszont nemcsak Wi-Fi, hanem Bluetooth 4.0 LE is szükséges. Az Apple azonban nem minden készüléken engedélyezte a Continuity-t, noha például a legtöbb pár éves Mac-modell hardvere képes lenne a Bluetooth 4.0 LE támogatására.

Ezen a problémán segít a tegnap megjelent Continuity Activation Tool, amely egy shellszkriptekből összeállított alkalmazás. Az app gyakorlatilag a készítője által korábban leírt manuális folyamatot automatizálja: megkeresi a megfelelő kernelmodulokat (“kext”-eket) az OS X-ben, és patcheli azokat, hogy feloldja az Apple által gyárilag beállított tiltásokat (blacklisting). Ez elsősorban a Bluetooth-t és a Wi-Fi-t kezelő kexteket jelenti.

A szkriptek készítője, Dokterdok szerint az alkalmazást a következő gépeken tesztelték:

  • MacBook Air 2008-2010
  • MacBook Air mid-2011
  • Mac mini 2009-2010
  • Mac mini mid-2011
  • MacBook Pro mid 2009…late 2011
  • iMac 2008-2011
  • MacBook Pro late-2011

Ezek közül a mid-2011-es MacBook Air és Mac mini kivételével mindegyikhez szükség van a hálókártya hardveres frissítésére, az iMac-ek esetében pedig mind a Wi-Fi-, mind pedig a Bluetooth-kártyát frissíteni kell. Fontos, hogy a gépben beépített Bluetooth 4.0-támogatásnak kell lennie, az USB-s Bluetooth-“dongle”-ökkel nem működik a patch.

Az app ellenőrzi a rendszert a patch alkalmazása előtt, és az eredeti, “szűz” kextekről készít egy mentést, hogy amennyiben bármi rosszul sülne el, akkor vissza lehessen állítani a gyári fájlokat, és ne legyen tégla a gépünkből. Ha tehát az app azt írja ki, hogy a rendszerünk/gépünk nem támogatott, akkor erősen ellenjavallt a “force patch” opcióval élni — a rendszerbinárisok helytelen módosítása tönkreteheti az OS-t!

Az érdeklődők számára az alkalmazás és forráskódja elérhető a GitHub-on.

Ezek még érdekelhetnek:


  1. Az az erdekes, hogy nekem 2011 mid iMac gepem van es semmit se allitgattam a hivasok megis megjelennek a szamitogepen, holott ugy tudom, hogy ezt az evjaratot mar nem tamogatja. Sajnos az Airdrop viszont nem mukodik, pedig ennek orultem volna a legjobban.

  2. MacBook Pro mid 2009…late 2011

    Ezen gepeknel is szukseges a kartya frissitese. Lehet be is szerzek egyet, mert eleg egyszerunek tunt a megoldasa.

  3. Nálam ezzel a cuccal mid 2011 minin félig-meddig máködik az airdrop.
    Látja az ios eszközöket és tudok is küldenei a gépről az iPhonera, illetve az iPadra.
    De visszafelé nem jelenik meg a mac mini… 🙁

    Azért elég hihetetlen, hogy 3 éves gép nem támogat ilyen funkciókat. Nem azért vettem, hogy sűrűbben cseréljem mint a más az alsónadrágját…..

  4. @baumgartner: nem értem az Airdrop-ról miért lettünk letiltva, hisz az Massages-ben meg eltudom küldeni a fájlokat. iPhone és iPad 2 között működik az Airdrop, de csak akkor ha nincs készenlétben valamelyik készülék, ami baromság, mert ezekben van energiatakarékos Bluetooth ami felébreszthetné az eszközt.

  5. Sziasztok. 7.1-es MacBook-al (white) miért nem működik? Először mindenképpen kell hardvert frissíteni? Na én olyant hol találok, amiben van bt 4.0?

  6. @mazsi1911: ez jó hír, a páromnak 2010-es MacBook white-ja van, immár Yosemite-tel, a 4S-én viszont még “csak” iOS 8.0, mert a 8.1-es frissítésre még nem kerítettem sort… de ezek szerint a hívások és sms-ek (nem csak iMessage) menni fog, szuper! 🙂

Írd le a véleményedet! (Moderációs elveinket ide kattintva olvashatod.)

Hozzászólás írásához be kell jelentkezned!